SOFTROCK TXRX NOTES


On Sep 20, 2015, at 1:20 PM, Leif Asbrink leif@sm5bsz.com [softrock40] <softrock40@yahoogroups.com> wrote:

Hi All,

Here is a video that shows the noise floor levels both in receive and transmit:

https://www.youtube.com/watch?v=UBT-DT-oZuI

In receive, the dynamic range is about 110 dB (500 Hz) at a separation of 2 kHz and the noise floor in transmit mode is compatible when I use a Delta 44 at maximum audio level followed by resistive voltage dividers to set the appropriate level for the Ensemble.

Other soundcards may produce much higher noise levels in transmit.

Leif


From: "Roger Graves ve7vv@shaw.ca [softrock40]" <softrock40@yahoogroups.com>
Subject: Re: [softrock40] Testing a Softrock Ensemble RXTX
Date: September 24, 2015 at 4:50:10 PM CDT
To: softrock40@yahoogroups.com
Cc: leif@sm5bsz.com
Reply-To: softrock40@yahoogroups.com

As Chris just noted, Leif has a fascinating video showing his testing of both RX and TX of an RXTX which he reported on this site on 20 Sept. I have been digesting all the great info there. For me, the take home results are (all with his Delta 44 soundcard):

1) the RX sensitivity is very good. On 20 mtrs he found a 17 dB noise figure, which I believe would correspond to a -130 dBm 500 Hz BW 3 dB S+N/N sensitivity. That is about what has been reported for the Ensemble II, so the switch and other differences in circuitry in the RXTX would seem not to have degraded the sensitivity. This is comparable to most conventional radios. To get this sensitivity, he had to have a clean power supply.

2) the RX dynamic range was outstanding, 10 dB better than any conventional radio shown in the Sherwood tables. There was very little added noise 2 kHz away from a maximum level carrier. To get optimum range, you have to adjust the soundcard gain so that it is not too great - the soundcard only (input shorted) noise shown on the software display should be just below the noise level when the RXTX is connected.

3) He found that spurs within the audio passband (i.e. shown on the software spectral display, Linrad, Rocky) were reduced if he added a small capacitor (e.g. .047) from the coax connector shield to the audio ground. I tried this on my RXTX (50 ohm dummy load on the RF input) and found no obvious change. I also found that all the spurs visible with the RXTX when supplied with 13.8 Vdc from a transformer power supply were not present on an Ensemble II, so the spurs may be an RXTX issue. My RXTX showed far lower level of spurs with a 13.2 V battery - my high spurs with the power supply might be a wiring, common mode path, issue.

4) The TX performance was also very good. He had to reduce the drive level to aprox. 1/2 watt output to get what he considered a reasonable level of within band (e.g. within 20 kHz of the carrier) spurs. 

5) To get acceptable spurious noise close to the carrier, which he found was noise from the soundcard output not from the SoftRock, he had to set the soundcard output at maximum, then reduce the input to the RXTX with an external audio attenuator to get the 1/2 watt RF output level. When this was done, this spurious noise was very low, as good or better than most commercial radios

[Later: Lief also reported that for minimum soundcard noise on TX he had to use 96 kHz sampling rate. The noise got progressively worse with lower sampling rates on the D/A output.]

So, according to Lief’s results, for lowest spurious noise on TX, use the highest sampling rate and the highest output level for the TX drive soundcard, then reduce the drive with an audio attenuator.

6) The RX and TX results anyone else would get would depend on their soundcard. He implied that some sound cards would produce unacceptable results on TX.

7) Linrad, Lief’s software, is awesome for this kind of testing! I have installed it but it will take me sometime to learn how to set it up to look like Lief’s video. Now I know what to aim for.

Thanks Lief for doing this great work and posting the results for us.

Roger, VE7VV


From: "'Alan' g4zfq@onwight.net [softrock40]" <softrock40@yahoogroups.com>
Subject: Re: [softrock40] Testing a Softrock Ensemble RXTX
Date: September 25, 2015 at 12:42:01 PM CDT
To: <softrock40@yahoogroups.com>
Reply-To: softrock40@yahoogroups.com

Roger,

One of Leif's shorter videos, only 35 minutes. They all need a short summary like yours:)

I've installed Linrad in the past but have yet to find the persevereance to understand how to  set it up.

Of course it shows the potential although he says the Deltas will only work properly on XP so very few will be able to reproduce his results. I have used D44s on W7, noticed no problems but can't be sure.

I do use XP and Delta 44s, also a 1010LT. I find the RX spurious signals seen on them can vary a lot regarding the computer, which PCI slots I use and what other cards are fitted. And that's before I plug in the Softrock.. And then plug in the antenna.

I remember using "his" capacitor mod in the past, that removed some spurii in a certain situation, I think it removed noise due to a USB connection.

Switch mode PSUs must always be regarded with suspicion although there are good ones.

In the earlier days it was always reccommended to use no more than 0.5 watts for a clean TX signal. This must again be dependent upon the exact setup.

I'm not sure if Leif gives the PSU voltage he used? A video makes it difficult to find a few words or seconds of screen time...

Anyone wanting a clean signal from a Softrock, especially anyone who is going to use one as a driver, should see this.

But it does need these tests reproduced with modern soundcards on modern Windows.

73 Alan G4ZFQ